Share:
Share
Notifications
Clear all

Issues with Prusa Z axis

SusanOKC
(@susanokc)
Famed Member

Hi, Luke:

I took your advice and got a Prusa i3 MKS+! We got it assembled and the very first print or two worked great, then the belts got loose, we adjusted, X and Y now look pretty good but I think we're having trouble with the Z axis. We've done what we know to do and it *seems to be set up right, but you can see we're not getting a great result on the top of the calibration cube at all. We're using the default Prusa settings for .2 layer height and the "quality" level although we used 20% infill instead of the default 15. Note that the cube is measuring exactly 20mm for the X and Y axes; Z is 20.23

Any ideas on what to try next?  

Thanks so much!

IMG 9310
IMG 9309
IMG 9308
IMG 9307
Quote
Topic starter Posted : 11/03/2021 2:02 am
Luke
 Luke
(@lmf5000)
Expert Moderator

Hi Susan,

Nice to hear from you again 🙂

The pic is showing under-extrusion, especially visible on the bottom and top layers. The top looks particularly bad, there may be something else going on in addition to the underextrusion, but let's tackle that first and then let the print guide the next steps.

I've looked through your start script and saw this line:

M221 S{if layer_height<0.075}100{else}95{endif}

This is curious - it sets your flowrate to 100% if the layer height is less than 0.075mm, or 95% otherwise. Your layer height is 0.2mm so this line is kicking in and setting your flowrate to 95%. Some quick research indicates that this may have been somewhat of a hack added to improve the quality of the print with early printers and on early versions of the software (or the original software, which was Slic3r). Since your prints are under-extruded, the first thing to do is comment out that line by putting a semicolon in front of it, like so:

;M221 S{if layer_height<0.075}100{else}95{endif}

Also, check your e-steps, just to be sure (mark the filament where it enters the printer and 120 mm forward of that point, extrude 100mm, see how far the mark is from the entry point - should theoretically be 20mm, if more or less your e-steps are incorrect). If your e-steps are incorrect, do the e-steps calibration as explained in our videos.

Once your e-steps are good, turn the printer off and on again to reset the flowrate to 100% (important if you've printed with that script and it's already set your flowrate to 95%), then try reprinting the calibration cube with that line commented out. You should immediately notice an improvement. If the top and bottom layers still have lots of gaps in them, bump up the extrusion multiplier slightly here:

image

If you need a setting bigger than 1.1 to get good results, measure your filament diameter, and carefully observe the extruder to check if the filament is slipping or the extruder gear is missing steps, and report back.

Looking forward to your feedback 🙂

P.S. I saw your post about the speed being lower than expected (which post was subsequently deleted I believe). We can work on that too after the quality is up to standard 🙂

Regards,
Luke

ReplyQuote
Posted : 11/03/2021 10:42 pm
SusanOKC
(@susanokc)
Famed Member

Hello!  Thanks for your help. I adjusted the code as you suggested and that made a big improvement! We also measured the e-steps and they seem to be good. So now sometimes our prints look great but occasionally we're getting these lines, like there isn't enough filament or adhesion on occasional, random layers. We wondered if it was something to do with the temperature so we printed a temperature tower and anywhere from 210 to 220 looks great so we've left it at 215 (printing PLA+). That doesn't seem to be the problem. We extruded some filament cleaner thinking there might be a small filament jam but it seems to be all clear. Any ideas on what to try next?

Thanks!

P.S. My next thing to tackle is to learn how to split the layers with the Prusa slicer to adjust the infill for each.  And do you know if the Prusa will let me add more infill to certain parts of my print without changing the infill for that entire layer?

IMG 0066
IMG 0069
IMG 0065
IMG 0068
IMG 0064
IMG 0070
IMG 0067
ReplyQuote
Topic starter Posted : 14/03/2021 6:17 pm
Luke
 Luke
(@lmf5000)
Expert Moderator

Hi Susan 🙂

Glad it's improved somewhat. A lack of filament is exactly what's happening (in fact under-extrusion is by definition a lack of sufficient filament to fill in the space required in the print) - you can see clearly from the gaps in the top layer of the cube:

image

I use the top layer as a diagnostic tool because it depends almost exclusively on extrusion; the bottom layer will depend on nozzle-to-bed spacing as well as extrusion, and the sides won't show much until extrusion multiplier is way out of calibration. So, in your case you are currently printing with an extrusion multiplier of 1.0. I suggest you increase that to 1.05 initially and then print a calibration cube (or just the top half of one to save time and material) and see if the top layer gets sealed up. If not, increase EM further, in increments of about 0.02 (so try 1.07, 1.09 etc). If it gets blobby/rough that means you are now extruding too much filament and should dial it back down.

You set extrusion multiplier it from here (make sure you're in "expert" mode):

image

Did you check your filament diameter? I've never had a printer that needed a multiplier more than 1.0, and Prusa printers should be pretty well calibrated, so I'm curious as to the root cause for this to be happening. Is your extruder slipping by any chance?

---

To split and print just the top of the cube in PrusaSlicer, use the cut button:

image

Tell it to keep just the upper part:

image

And this is the result:

image

(all the diagnostic power of the top of the cube with only 25% of the resources 😉 ).

---

To adjust settings by height, like you did in simplify3d, you right-click the shape and click "height range modifier" -

image

Then on the right you enter the height range:

image

For example, I will make a band between 10mm and 15mm on my cube:

image

Then to override a setting you have to add the setting by either double-clicking or right-clicking the gear under "editing" -

image

And if, say, you wanted to override infill for that section you would click "infill". Now you can edit the infill for that range independently of the rest of the print - 

image

For example, if I set that to rectilinear and leave the rest as gyroid, I get this:

image

As you can see, the cube is printed with your default settings (gyroid), but the range between 10-15mm is printed with my override (rectilinear).

---

To override settings in a particular section (one of the neat features in PrusaSlicer that you can't do with Simplify3D), right click the model, add modifier and pick a shape:

image

I picked a box. You then move the box, resize rotate etc using the usual tools (on the left). For this example I will leave it on the bottom right of the calibration cube:

image

Now, as before to add overrides you right-click/double-click the gear near generic box and choose your override-

image

Once again I'm going to override it with rectilinear infill and up the density to 80% (since this seems to be your intention I guess, for extra strength in localised parts):

image

And the result is as follows:

image

As you can see, the area overlapped by the box has had its infill settings overridden. Now the shape you modify with can be a box, cylinder, or any arbitrary shape that you import as an STL (so you could even design custom shapes then import them as modifiers if a box or cylinder aren't quite up to the job).

Hope this helps! Let me know how the trials with different extrusion multiplier go. 🙂

 

Regards,
Luke

ReplyQuote
Posted : 15/03/2021 11:58 am
SusanOKC
(@susanokc)
Famed Member

Hi, I just wanted to reach back out to say the prints are PERFECT now! And all of those slicing techniques worked great - no trouble at all. Thank you so much!  I have one new question I'll post in another thread. 

ReplyQuote
Topic starter Posted : 27/03/2021 4:00 pm
Luke
 Luke
(@lmf5000)
Expert Moderator

Awesome, glad to hear it! 😀

Regards,
Luke

ReplyQuote
Posted : 27/03/2021 8:50 pm
Share:
Share

About us

We’re a bunch of 3D printing and design nuts. We just want to make great 3D design available to everyone. 

Our mission

Good design takes time, great design takes a process. You can learn this with us, to build your skill set in this rapidly expanding market. 

Learn with us:

© Copyright: 2019 io3dp.com
Close Menu