Share:
Share
Notifications
Clear all

Bed Levelling

Page 1 / 4
Jess
 Jess
(@jess-2)
Community Manager Admin

* Posted on behalf of a member*

Went to try .stl files for patterns for checking bed levelling.  The printer went through auto levelling, then head went to front LH corner of bed and crashed then stopped.

Using: Creality CR20 with 235mm x 235mm glass bed and auto levelling.,   Creality version of Cura, using all the preset settings I normally use for all my printing.

Tried the 200 x 200, then 150 x 150 and then centre only pattern. All with same result.

Glen Chamberlain

Quote
Topic starter Posted : 25/06/2021 10:05 am
Pablo
(@placherre)
Member Moderator

Hi Glen! 

Welcome to the Community! I apologise for the late response…

I am sorry to hear that. Let's find out what is going on.

Thank you for the information you provided. But, I will require more details regarding configuration and settings in order to find the correct source of your problem. 

First, just to see where the problem is, the auto levelling procedure is correct; but the problem is when trying to print the .STL file to check the bed levelling, is that right? If so, please send me .STL files you are trying to use and the GCODE generated. In order to do that, go to the File tab and then select Save GCode. That file will give me more information too.

Also, when you refer to “Creality version Cura” you are meaning that the Slicer you are using is the one provided by Creality, is that correct? If the answer is yes, please send me a screen capture of the machine settings. In order to do that, go to File > Machine Settings…, then a window will show up. That is the information I will be needing. You can find the same information under the Machine tab and then click on Machine Settings…

One more thing. Please, send me the Start/End GCode. That information is under the full settings. In order to find out that configuration, click on the Expert tab. Then, you will see more settings tabs. Select the Start/End GCode (last one) and take a screen capture of the start GCODE lines. You should be seeing something like this:

Creality Start End GCode Screen Cap

I look forward to hearing back from you.

Kind regards,

Pablo

ReplyQuote
Posted : 26/06/2021 10:45 am
GlenC
(@glenc)
Trusted Member

Hi Pablo. Thanks for your reply. I think I have assembled the correct information you have requested.

End Gcode
Start Gcode
machine settings

 

ReplyQuote
Posted : 30/06/2021 10:29 am
Pablo
(@placherre)
Member Moderator

Hi Glen!

Thank you for the information! I will take a look at what you sent and I will reply you back.

Regards,

Pablo

ReplyQuote
Posted : 30/06/2021 3:51 pm
Pablo
(@placherre)
Member Moderator

Hi again Glen!

I have been looking at the pictures and files. When I took a look at the Gcode, I found there are no coding lines, which describe the printing sequence. When you take a look at the lines, you can notice the start Gcode lines and then the end Gcode only. The printing coding lines should be between M106 and M107. But, in the Gcode you sent, there are no lines. If you want, you can check the Gcode using the following link: https://gcode.ws/ . Also, you could change the extension of the .gcode file to .txt; but first make sure that you made a copy.

This is how the Gcode should look like:

Taking a closer look at the slicer settings, I noticed that the initial layer height was setted up higher than the model thickness, which is 0.2 mm. Due to this, the printing code won’t be consistent with the model you are trying to print. Therefore, you should change the initial layer to 0.2 mm. In order to do this, click on the Advanced tab and look for the Quality settings. The one that needs to be adjusted is the first setting, Initial layer thickness (mm); that number should be set to 0.2 mm. By doing that, the slicer will generate the correct Gcode for the model. In the following picture I am showing the settings I mentioned.

First Layer Thickness   Creality

Something else I noticed is that the Retraction Speed is set up as default in 80 mm/s, which is very high for a Bowden system. Normally, this value should be between 20-30 mm/sec for Bowden extruders, for better performance. I would recommend you to change that value if it isn’t in the mentioned range. You will find this setting also under the Advanced tab, in the Retraction title. The Speed (mm/s) setting is the first one. Since the CR 20 extruder is similar to the Ender´s 3, I would set it up to 25 mm/s. Let me know if this value was out of range when using the default settings. In the next picture you will see where it is located.

Retraction Speed   Creality

Attached you will find the model ready to print, sliced with the Creality program. If you like, try to print the model with your configuration and then try to print the file I am sending you.

I do not want to rush things, but I would recommend you to start using Cura or Simplify3D. These two programs will give you more settings to play with in order to obtain reliable prints. But, if you are starting, go one step at the time. Since you are using the Creality slicer, the change to the Cura interface won’t be so hard. Anyways, feel free to share your thoughts.

If you have any questions, please feel free to write back to me.

I am looking forward to your response.

Kind regards,

Pablo

ReplyQuote
Posted : 30/06/2021 5:32 pm
GlenC
(@glenc)
Trusted Member

Hi Pablo, made the changes you suggested and was able to print. Result showed I was not getting a level bed. My CR20P has a BL Touch auto bed levelling system. When I used the Creali

ty slicer, it went through the bed levelling sequence at the start of each print.

      Took your suggestion to go to Cura 4.10.0.  I set the Z offset in the recommended fashion, using paper and calculation. Sliced and ceated the G.code for 200X200 bed levelling test.  Printed the test and found high point on front RH corner where the test square seemed to print perfectly. The prints deteriorated diagonally across the bed and to a lesser degree on the back RH corner and front LH corner.(stringy and not adhering very well).

             I tried doing an 'Auto leveling' from the printers menu, then a 'store settings'. Then printed again, with same results, as though the auto levelling had no effect at all.

          Is there some way to see if the Auto bed levelling is working and am I right in doing the 'store settings'?

Have attached the G.code I made in Cura.

ReplyQuote
Posted : 06/07/2021 12:26 am
Pablo
(@placherre)
Member Moderator

Hi Glen!

I am glad you were able to print the model test properly! Let’s figure out what is the issue related to the uneven bed levelling. By any chance, did you take pictures of the squares? If not, would you print the model one more time? I would like to see each square individually. I took a look at the file you sent and I noticed you skipped the G29 command for the auto levelling; maybe you could add it like you did before.

Regarding your question, you mentioned you did the manual calibration. Did you have to adjust any of the knobs? If the manual calibration is correct and you have issues with the auto levelling, the problem is related to the probe alignment. Actually, the auto levelling is an enhancement of the manual levelling. Therefore, I would suggest you to perform a manual levelling of the bed with the four knobs and a sheet of paper. Have in mind to verify the nozzle tip is properly clean when doing the manual levelling. Otherwise, you will end up having misalignment between nozzle and bed. I would suggest heating up the hot end in order to clean it; but, be careful when doing this, you could burn your fingers. In order to do it safely, I recommend you to use paper tissue and pliers. Then, run the auto levelling. Make sure the springs are not fully compressed.

In addition, the presence of debris along the bed surface could lead to misreading affecting the levelling. Also, would you send me pictures from the BLTouch sensor? In order to see if I notice something that is out of place. If the alignment is not correct, the plane resulting from the auto levelling will be at an angle from the bed’s plane. As a result, the printing plane will be offset from the bed. For example, in one corner the print pattern could be the correct one; but in the opposite one, the printed layer could show signs of a high offset between the nozzle and the bed.

One last question for now, have you ever connected the printer to your PC/Laptop? If yes, please tell what program you used.

I hope the explanation was useful. Let me know how it goes.

I am looking forward to your response!

Kind regards,

Pablo

ReplyQuote
Posted : 06/07/2021 5:50 pm
GlenC
(@glenc)
Trusted Member

2 things:  1. This model CR20P does not have any levelling knobs. The Bed is securely fixed via spacers and obviously relies entirely on the auto levelling. I did try putting some shim packers under the glass bed to compensate for the out of level pattern I described, but not too successful. Should I be looking for some modification kit to give me levelling knobs?

2. the G29 instruction was already part of the set up in the Creality slicer.   Could you tell me where and how I should insert it into the Cura 4.10.0?

ReplyQuote
Posted : 08/07/2021 2:34 am
Pablo
(@placherre)
Member Moderator

Hi Glen!

Thank you for the advice. Since you mentioned CR20 in the first post, I mentioned the manual bed levelling before performing the auto levelling. Because that model comes with the adjusting knobs. On the other hand, the CR 20 Pro model has a fixed bed. That is kind of tricky when trying to make some manual adjustments, but I will come up with a solution. 

Recalling the last file you sent, I notice you were able to add your printer correctly in Cura. Just in case, I will show you how to add your machine. Once you open the slicer, go to the Settings > Add Printer:

CR 20 Pro   Cura Printer Settings Root

In the following window select Add a non-networked printer tab and then, select Creality3D from the list. Next, a list of printers from Creality will be displayed; in your case it will be Creality CR-20 Pro:

CR 20 Pro   Cura Selection List

The next window will show the Printer and Extruder default settings tabs:

CR 20 Pro   Cura Settings

If you take a look to the Start Script, you will notice a command named M420 S1. This code enables the bed levelling compensation. This command is written after the G28 line, which disables auto levelling. In this case, you could add the G29 auto levelling command before the G28, resulting in the following Start script (modification is in red):

 

M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration

M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate

M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration

M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk

M220 S100 ;Reset Feedrate

M221 S100 ;Reset Flowrate

 

G29 ;Auto Levelling

G28 ;Home

M420 S1 Z2 ;Enable ABL using saved Mesh and Fade Height

 

G92 E0 ;Reset Extruder

G1 Z2.0 F3000 ;Move Z Axis up

G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position

G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line

G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little

G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line

G92 E0 ;Reset Extruder

G1 Z2.0 F3000 ;Move Z Axis up

 

The compensation command makes the nozzle move parallel to the bed, correcting any uneven area of your bed. If the compensation is enabled and the bed is not levelled, the printer will apply a Z axis correction while printing the bed level STL. Since it could be a small displacement, look very closely to the Z axis lead screw or place your finger in the coupler. Then, you should notice some minor movement on the Z axis.

If the compensation is enabled, and you still have issues with bed levelling I would guess you have mechanical issues. For example, did you have the chance to check for any loose bolts or nuts? Do you have the chance to measure the parallelism between the X gantry and the frame? If so, please send me both measures in order to see if there is any significant difference. I am attaching the following picture for reference:

CR 20 Pro   X Gantry Measure

Also, check if the bed is loose. If the eccentric nuts (placed between the two right hand wheels) are loose. If loose, this could lead to improper alignment causing the bed to wobble. When printing, one side of the bed goes up/down and makes the bed slanting. On the contrary, if you over tighten those eccentric knots you will notice that the bed is hard to move. Take a look at the following picture for reference of the eccentric knots:

CR 20 Pro   Eccentric Nuts

Also, whenever you have the chance, send me the pictures of the probe’s installation; in order to check if there could be a misalignment. Finally, would you send me the Firmware version? You can find this information in the LCD menu in About Pinter. I have been doing some research and there could be a bug issue for some versions. But I believe this is not the reason. I just want to make sure we have covered all the options. In my opinion, it is a mechanical related issue.

 

I hope I was helpful with the comments… 😀 

 

If you have any further questions, please let me know.

 

Kind regards,

Pablo

ReplyQuote
Posted : 08/07/2021 2:57 pm
GlenC
(@glenc)
Trusted Member

Hi Pablo,   Some details after trying to get bed levelling perfected on Creality CR20P.

Firmware Version is: Marlin 1.1.6

Gantry to Frame Dimensions as per your sketch:

                        LH side  163.8 mm           RHside   164.3 mm

Checked eccentric nuts on 2 RH wheels under bed. Were a little loose. Could get a small amount of movement in the bed. Tightened till no movement, but bed free to move back and forth.

      Made change to G Code to insert G29 as per your instructions. (have attached new file)

      Had the following problems: 9 point Bed levelling procedure cuts in sometimes, but not every time.   Several times it wanted to commence the levelling at a point out side the area of the bed and had to be turned off quickly as it wanted to crash into the corner of the bed.

 

      These happened as I repeatedly ran the 200 x 200 bed levelling test print. I was gradually adding shims under the spacers holding the bed on LH back and to a lesser extent on the LH front. I had to also keep adjusting the Z-Offset until I eventually got a pretty consistent set of squares printed.

   I then printed a test print of the D ink robot and achieved a good result.   Previously I could only get a print if I employed a raft. But on this one, it did not go through the bed levelling even though I had the G29 command in place.

       When I do go through the 9 point levelling, sensor point is very much biased to the LH side of the Bed.  I have attached some photos of the position of the sensor at each

of the 9 points.

  Attachments:  1.  G Code for the 200 x 200 test, including the G29 command positioned as you suggested.

  1. Photos of extruder head positions at the 9 points of bed levelling.
    P1020369
    P1020371
    P1020370
    P1020367
    P1020372
    P1020368
    P1020366
    P1020374
    P1020375

     

ReplyQuote
Posted : 16/07/2021 9:14 am
Pablo
(@placherre)
Member Moderator

Hi Glen!

It is good news that you can print the model, despite the auto levelling problem. 

Thank you again for the information and pictures provided on this occasion. I will analyse all the facts and I will reply to you back.

Just a quick question. Is the pin’s probe bent to the side?

Kind regards,

Pablo

ReplyQuote
Posted : 16/07/2021 4:45 pm
Pablo
(@placherre)
Member Moderator

Hi back Glen!

I came up with the following suggestions.

Regarding the gantry distance, there is no problem. The difference between both distances is below 1 mm, which is really good. Also, it is good to know that you were able to adjust the bed adjustment in order to prevent wobble when printing. This last thing probably was the main problem you had when printing the levelling model. Because the Nozzle puts some pressure over the Bed, forcing it to go out of level.

Regarding the problem of the printer going outside the bed, I believe it is related to the BLTouch probe. Regarding your model, it doesn’t have an end-stop switch for the Z-Axis. Because the manufacturer relays that the BLTouch sensor will perform the stop before hitting the Bed. Therefore, this leads to problems if the probe is not working properly. In the worst case scenario, you won’t be able to print if the sensor is damaged and you must remove it. Unless you have a spare part, which will let you change it immediately. In addition, there is an issue related to the firmware installed from the factory (Marlin 1.1.6), which I will explain later on.

Just in case, I am going to describe the Z-Offset procedure, in case you might be missing something on the way. First, you should check the Z Offset. You can verify this number scrolling through the LCD screen: Control > Motion > Z Offset (let’s call this number B). This number is the difference between the probe and the nozzle, which is always negative. Once you have that value, select Auto Home and wait until the nozzle goes to the specified place. Next, check with a piece of A4 paper the distance. If you can place the paper without resistance or you can’t place the paper between the nozzle then, you should adjust the Z Offset. In order to do this, scroll to Prepare > Move Axis > Move Z > Move 0.1 mm; then increase/reduce the distance in order to be able to fit the paper with some resistance. Once you have that Z value, write it down (let’s call this one A). Then, the new Z Offset value is the difference B-A. Finally, go back to Z Offset (Control > Motion > Z Offset) and update this value by rotating the knob. Finally, to verify the value is stored properly (Configuration > Store Settings). If you hear a beep, the value has been stored correctly.

Still, I am concerned that auto levelling is not being performed properly by the printer. The first thing I noticed is that the BLTouch pin is bent to the side. The deformation happened the one time the hot end crashed the bed? In that case, the probe might have issues setting up the proper auto levelling. In the following link you will be able to download a protection for the pin in case gantry goes down and impacts the bed:

https://www.thingiverse.com/thing:3419174

I would recommend you to fix it. Since it is bent, there might be a chance that the probe could send misreading to the board. The good thing is that you can find a replacement for the pin:

https://www.amazon.com/-/es/BLTouch-Push-Pin/dp/B07L5T2LNW

But, if you are courageous enough, you could put the damaged end of the tip in hot water and try to straighten it since it is made from plastic.

I have been doing some research and I found there is a problem related to auto levelling and Firmware, especially with Creality CR-20P. Therefore, I will guide you through the firmware update process. The procedure involves an HEX file extension (I will attach it at the end of the reply) and a USB cable, which will be used to connect the printer to your PC/Laptop. Basically, the .HEX file has the information required for programmable devices, such as the microcontrollers of every printer. Since the PC/Laptop will not be able to communicate with the printer by just plugging in the USB cable, you should install the proper driver in order to be able to transfer information between both devices. Attached at the end of this reply you will find a file named CH341SER.EXE. Download it on your computer and install it (double click). You should see a windows like this one:

CH341 Main Window

Once you install it, you will see the Serial port installed:

Device Manager Serial Port OK

If the driver is not installed properly or it is not installed at all, the Serial port should show a warning:

Device Manager Serial Port Not OK

I have done this for my Ender 3 Pro and I have been able to connect them. In my case, I use it to perform some temperature auto tuning.

Now, let’s do the Firmware update. Before doing anything else, make sure you have the HEX file and the USB cable accessible. Also, open Cura and turn on your printer. Once you have everything ready, you can start to update your firmware:

1- Connect the PC/Laptop to your Printer.

2- In Cura, select Setting > Printer > Manage Printers…

3- Select your Printer and then click in the Update Firmware box.

4- Next, a window will pop-up; select Upload Custom Firmware.

5- Then, select the .HEX file I sent you.

7- Now, there will be a loading bar displaying the upload progress.

8- Finally, your printer has the updated firmware.

With this new firmware, the Z-Offset procedure is quite different to the previous one. In this case, the steps are the following:

1- For better performance, heat up the Nozzle and the Bed to the working temperatures. This is beneficial regardless of the Firmware, it is just a good practice when doing manual levelling or Z-Offset adjustment. Because the heat expansion compensates for any difference when cold. Retract some filament, in order to prevent spillage, which could affect the calibration.

2- Auto Home the Printer.

3- Move the Printer’s Axis to 0. When doing this, place the piece of A4 paper underneath the Nozzle.

4- Select Configuration > Probe Z Offset. Then, move up/down the Nozzle until you are able to move the piece of A4 paper with some resistance. 

5- Finally, save the new Offset value in Configuration > Store Settings.

Before starting printing again, I recommend you remove the shims you placed. Let the BLTouch probe do all the levelling work. Were you able to check if the compensation is enabled? I made a comment about this in my last reply (after the GCODE commands).

From now, if the auto levelling process doesn’t have any issues, you could remove the G29 line from the Star script. There is a discussion among makers if it is necessary to perform auto levelling once every few prints or before every print (by adding the command in the start script). But, this is up to you and how you manage your experience.

I hope I was able to help you with the issue. Since the explanation is too extensive, do not hesitate to ask me if you have any questions.

Good printing!

Kind regards,

Pablo

ReplyQuote
Posted : 17/07/2021 1:46 pm
GlenC
(@glenc)
Trusted Member

Hi Pablo.  I have taken a while to take action on your last reply to me. (have been a bit crook with some darstedly virus that has been circulating - fortunately not the Covid one!) Have run into a few problems. I successfully straightened the BL touch probe using the hot water approach.

Downloaded the CH341SER file and attempted to install. Got a message ,"the drive is successfully installed in advance". Nothing showing in the Device manager under Ports (com & LPT), and no warning.

     Connected the CR20P with USB cable to Desk top computer running Windows 10. Checked Device Manager and found an entry under 'Other Devices', showing FT232R USB UART., with a warning sign.  Did right click and opened update driver. Tried both Search automatically and Browse my computer to get driver, and got, 'Windows was unable to install your FT232R USB UART.'

     Opened Cura... Update firmware. Says no connection between Printer and Computer.

   I'm sort of stuck!

Glen

ReplyQuote
Posted : 15/08/2021 8:10 am
Pablo
(@placherre)
Member Moderator

Hi Glen!

Thank you for your reply!

I am glad that it wasn’t Covid-19, just a normal flu… 👍 

It is good to hear that you were able to bend the tip of the probe. It might be tricky sometimes if the part is not under some temperature; because it might end up braking.

Since the previous step hasn't worked, I would suggest you to use another driver, which can be downloaded from the following link: https://www.th3dstudio.com/hc/downloads/drivers/creality-printer-drivers-ft232r-chip-most-models/ . Normally, this driver is included in the SD Card that comes with the printer. If not, you can download it from the previous link or from the attached ZIP files. The file I sent you in the previous reply works for printers which have the main board V1.1.4. Therefore, I believe your printer has a newer version. If you have the chance, please let me know which board version your printer comes with. In order to do this, you will have to take out the cover to have access to the main board. Generally, the number is located in the middle of the PCB, where the brand of the printer is.

Once you have the file, place it in the SD Card and put it into the card reader slot of the printer (just like when you are going to print). Next connect via USB the Printer and your C/Laptop and run the setup file or installing the driver. Also, you can use the Device Manager and update the driver by browsing the file on the SD Card. Make sure to choose the update option for the listed hardware with the yellow icon (the one named FT232R USB ART with the warning sign). 

Since you have Windows 10 installed, the driver should be installed automatically. If not, follow the steps mentioned in the previous paragraph.

I have never used Cura to connect my computer with my printers, since the first time I felt more confident using another program to send GCodes to my printers. I read some posts on the internet and the Community and there are people having issues when using Cura to connect their printers. Therefore, based on my experience and those comments, I recommend you to download Printrun using the following link: http://kliment.kapsi.fi/printrun/ . Since you are running Windows, download the Printrun-win-18Nov2017.zip. The name suggests it is old, but don’t worry it is the last update. Next, unzip the files in a normal folder and run the pronterface.exe file, which will open the software. Be aware of the following: the printer must be connected before opening the Pronterface; otherwise, the software won’t recognize it.

The interface of Pronterface looks like this:

Pronterface Window

On the left side you will see connection ports and baud rate (speed which information is shared), XYZ movement commands, Bed and Nozzle Temperatures (with a graph) and printing speed. On the centre, with the small division, is the 3D preview of the printing process. Finally, on the right hand side you will see the information panel, showing GCode commands and the communication status between the Printer and the PC/Laptop. 

On the left top corner, you will be able to choose the port name and the baud rate. In most cases, the default value (115.200) works fine for most printers. Once you have both selected, click Connect and the Printer and PC/Laptop will start to communicate. Therefore, on the right side box you will see some lines regarding the communication status. In order to make sure the printer will respond, move any of the axes by small increments.

Now that we are sure you were able to establish a connection with your printer, next, I will explain to you how to install the new firmware on your printer (.HEX file). Since you have Cura installed, I will show you how to do it with this Slicer. If it doesn’t work, let me know and I will explain to you with a different one. 

First, click on Settings > Printer > Manage Printers (remember to stay connected at all times and the Printer turned on). On your Printers list, select the one you want to upload the firmware and click the Activate icon to make sure you selected the correct Printer. Then click on the Update Firmware icon (shown in the picture below).

Update Firmware Icon   Cura

Next, click on Upload Custom Firmware and select the HEX file I attached in the previous reply. Now, a progress line should be displayed while the firmware is uploaded. During this process, do not attempt to make anything with your Printer and your PC/Laptop.

Finally, once the uploading is finished close Cura and open Pronterface and connect your Printer in order to verify the installation of the new firmware is correct. To do this, check the new version of the firmware on the information box. 

In conclusion, now you have installed a firmware with the auto-levelling feature updated (fixed from bugs). Also, you were able to correct the probe’s pin, which is straight again. 

Since it has been a long process from stablishing connection between the Printer and your PC/Laptop and installing a new firmware. Please, if you are now sure of something, please let me know so I can assist you with any doubts you might have.

I am looking forward to your response.

Kind regards,

Pablo

ReplyQuote
Posted : 17/08/2021 12:02 am
GlenC
(@glenc)
Trusted Member

Checked Board. says Creality V2.2

ReplyQuote
Posted : 17/08/2021 2:18 am
Page 1 / 4
Share:
Share

About us

We’re a bunch of 3D printing and design nuts. We just want to make great 3D design available to everyone. 

Our mission

Good design takes time, great design takes a process. You can learn this with us, to build your skill set in this rapidly expanding market. 

Learn with us:

© Copyright: 2019 io3dp.com
Close Menu